SYMPTOMS
Due to security changes made in macOS Mojave and onwards, Modo may require additional privileges to perform specific functions.
This may cause problems when users try to save or edit specific content or attempt to make changes to Modo’s installation environment through the application.
CAUSE
As Modo doesn’t have the required privileges to perform actions such as saving or overwriting existing files, users may encounter permission errors.
RESOLUTION
The following steps show users how to grant Modo the additional privileges that it may require on macOS Mojave.
1. Select the Apple icon in the top left of the screen, then choose System Preferences… from the resulting pop-up window.
2. Select Security & Privacy from the resulting System Preferences window.
Image 1: The “System Preferences” menu on macOS Mojave
3. In the Security & Privacy window, select Full Disk Access under the Privacy tab.
Image 2: The Privacy menu in macOS Mojave
4. Ensure the lock icon is unlocked. If it is not, click the icon to unlock it.
5. If the version of Modo you are using is not listed in the Allow the apps below to control your computer box, select the + icon underneath the box.
6. Navigate to whichever Modo version you're using in your installation directory, then select it and press Open.
Modo should now have the required privileges to run as expected.
NEXT STEPS
To test Modo in a clean environment and verify if a plugin or kit is contributing to any unexpected behavior, you can run Modo temporarily without plugins or customizations by launching it in “Safe Mode.” Instructions on running Modo in safe Mode can be found in the following support article: Q100288: Launching Modo in safe mode
This may help to determine if issues such as this are due to Modo itself or something present within Modo’s installation environment.
FURTHER HELP
If you continue to encounter problems while running Modo in safe mode, please open a Support ticket and let us know the issue that you are encountering and the troubleshooting steps you have taken so far.
For more information on how to open a Support ticket, please refer to our article: Q100064: How to raise a support ticket
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