Q100504: What to do if an opened Project displays the Node Graph and palettes as empty

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SYMPTOMS

A project that was created in a Mari version earlier than Mari 4.5v1, which is then opened in a version between Mari 4.5v1 and Mari 4.6v4, may seem to have its Node Graph, Shaders, Channels and Layers Palettes non-active, regardless of the object selection in the Objects Palette. The Palettes appear to be empty even though there are still textures on the actual model.

This is resulting in the inability to create or change the Shaders, Channels or Layers. Furthermore, the Node Graph seems to be locked. The following image illustrates how the non-active palettes appear even though the object has been selected:

 

 

 

CAUSE

This issue occurs occasionally and it is mainly caused by a Converting Layers dialog that may appear on the opened Project. An example of the Converting Layers dialog is shown below:

 

 

This dialog is displayed when converting a project from any version of Mari to a version between Mari 4.5v1 and Mari 4.6v4, but may also appear when opening a project in more recent releases.

 

 

RESOLUTION

This issue was logged under the following ID, and has since been resolved in Mari 4.7v1:

ID 370320 - Project Opens Without the Current Object Populating Palettes

If you are unable to update to Mari 4.7v1 or later, the workarounds listed below can be used to resolve the issue:

  • Creating a Locator and switching back to the previous object reloads the Node Graph and the palettes. The Add Locator button is situated in the Objects Palette as shown below:

 

  • Reopening the project in the Mari version that the issue is being seen on resolves the issue as well.

 

 

FURTHER READING

If you are seeing any problems with the workarounds then

please create a support ticket and provide us with the information requested in this article:
Q100090: Information to send Support when reporting a Mari issue

For more information on how to open a Support ticket, please refer to this article:
Q100064: How to raise a support ticket

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