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Q100399: Unable to launch Mari 3.3v1 and above on AMD driver 17.12.2


SYMPTOMS

On some user machines using a graphics card running AMD Radeon Pro Adrenalin driver version 17.12.2, Mari 3.3v1 and above may crash or hang indefinitely during launch, regardless of whether or not it has been launched in safer mode. The same problem does not occur in versions predating Mari 3.3v1. 

 

CAUSE

At the current moment in the time, the exact cause of this issue is unfortunately unknown but we are aware that the problem seems to occur on machines with AMD cards, running the AMD Radeon Pro Adrenalin driver version 17.12.2. So far we have had reports from users encountering this crash and/or hang during Mari launch, on the following graphics cards:

  • Radeon Pro WX 5100
  • Radeon R9 390 Series
  • Radeon R9 380 Series
  • FirePro W8000
  • FirePro W9100

Mari, in general, is heavily reliant on graphics drivers in order to be able to correctly perform and execute GLSL shader operations on the GPU. Due to this, different driver versions and hardware combinations can sometimes have varying effects on how well Mari performs on an archive by archive basis.

We are aware that in cases such as this, some graphics cards and driver combinations have been reported to encounter issues when running Mari. We continue to work with graphics card manufacturers when these issues arise.

 

WORKAROUND

The easiest way to confirm that you are encountering this specific driver issue is to check whether or not you can successfully launch Mari 3.2v1 or any version predating Mari 3.3v1, whilst still using your AMD card on the 17.12.2 driver. You can download earlier versions of Mari from our Products Download page at the following link:

https://www.foundry.com/products/mari/download

If you are able to launch earlier Mari versions without running into a crash or hang, you should roll back your AMD graphics card drivers to 17.12.1.

In order to ensure that the 17.12.2 driver is removed correctly, we recommend using a driver removal application to completely wipe clean your GPU driver installation.

Within the Support team, we regularly use and test DDU (Display Driver Uninstaller) in order to wipe clean our GPU's before installing an older driver version, however if you prefer, you may use alternative driver removal applications providing that it thoroughly wipes clean any existing GPU drivers.

After doing this, you will need to download an older driver from AMD's website. Below is a direct link to AMD's official driver download page:

https://support.amd.com/en-us/download 

NOTE: Please ensure that you download the correct driver for your operating system.

 

FURTHER GUIDANCE

If you are still experiencing a crash after reverting back your AMD GPU driver, please open a Support ticket explaining how you are encountering a crash, and the troubleshooting steps you have already taken.

For more information on how to open a Support ticket, please refer to the Q100064: How to raise a support ticket article.

 

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