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Q100381: Nuke 11 immediately crashes when creating a Read node, or displaying the file browser

SYMPTOMS

Since the release of Nuke 11.0v1, there have been several reports of Nuke crashing immediately when creating a Read node, or when the file browser is displayed. Nuke scripts can still be opened through Windows File Explorer, and it is still possible to drag in .nk scripts and other files into the Node Graph/Bin window.

The crash occurs when the machine uses certain network protocols to mount network drives, and does not occur if the network drives are unmounted. 

So far, we have had reports of crashes happening only on Windows, and mounted with connections from the following: NFS, Egnyte and Avid Nexis. Currently, we have had no reports or have been able to reproduce this crash on SMB/Samba connection types.

This issue only started to occur in Nuke 11.0v1, and was not present in Nuke 10.5v7 or earlier. This crash appears to happen in Nuke, NukeX, NukeStudio and Hiero.

CAUSE

The crash occurs inside Qt, and happens when the file browser is trying to initialise favourites.
The issue was introduced in Nuke 11.0v1, due to the upgrade of the Qt version to 5.6.1 in order to be VFX Reference Platform compliant. 


WORKAROUND 

We have been able to reproduce the problem internally and have logged it under the following bug report:

TP 329787 - [Windows] Nuke crashes when showing file browser with NFS drive mounted

This bug is now closed and should have been addressed in Nuke 11.1v2.
 

If you are encountering this crash, it may be necessary to upgrade to the latest version of Nuke, which can be downloaded here

NOTE: We have had one user report that when the network drive is unmounted and they use the full network path (UNC), for example \\server\volume\path, the crashes no longer occur and they can access the files from the network. This may be a viable workaround but we have not been able to confirm this in house.

FURTHER HELP

If you are experiencing a similar issue in an operating system other than Windows, in a version of Nuke earlier than 11.0v1 or in Nuke 11.1v2 and later, please open a Support ticket. Please let us know the symptoms of the issue, the troubleshooting steps you have taken so far and the details of any network drives you may have mounted to your machine. 

More information on how to open a Support ticket can be found in the Q100064: Using the Support Portal article.

 

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