Q100432: Nuke crashing with 'Assertion Failed' error message

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SYMPTOMS

Several users have reported seemingly random crashes in Nuke on Windows 7 and 10, with an error message in the terminal similar to the following:

Assertion failed: Address already in use (..\..\..\src\signaler.cpp:310)

The crash occurs during normal use of Nuke without any deliberate actions from the user. This issue has been reproduced internally on both Windows 7 and 10.

 

CAUSE

The crash originally seemed to have been introduced by a compatibility issue between Nuke and a specific build of Windows, which from our internal testing seems to be OS Build 17134.165 for Windows 10.

However, we have received reports of this error still occurring for some Windows users, even after installing these updates. The Assertion failed error message comes from ZeroMQ, which is a third party library that Nuke (as well as other software) uses for it's port management. 

  • Sometimes security software may see how ZeroMQ is utilising ports as suspicious and block this sort of activity.
  • You may have another process which is already using a port that ZMQ is also trying to use. 

These conflicts typically occur on the ports used by Nuke's frame server, and you can find more information about this from the following article:
Q100459: Ports used by the Nuke Frame Server

 

RESOLUTION

Internally we were able to resolve this issue by installing the latest Windows updates. This has been supported by reports from users who are no longer experiencing the crash after installing the latest updates. These specific updates that fixes the issue on their Windows machines were as follows: KB345421, KB2267602, and KB4340917 

For more information on how to manually scan for and install Windows updates, please refer to the this page on Microsoft's website.

If you have already installed the latest Windows update, and are still encountering this error, we would then suggest running the following tests, to see if the problems still occurs:

  1. Launch Nuke with the frame server disabled:
    Q100378: How to disable the Frame Server for Nuke, Nuke Studio and Hiero

  2. If possible, temporarily disable your firewall and any other security software that you may have installed, including Windows Defender, then launch Nuke as you normally would.

If the errors do not occur in either of the tests above, then you may need to allow the necessary ports through your firewall, or security software. Alternatively, you may need to ensure that no other processes are also trying to use the ports needed for Nuke's frame server.

 

FURTHER READING

If you have tried the steps above, and you are still unable to determine the cause of the problem, please open a Support ticket and let us know the exact version of Nuke and the exact build of Windows that you are using, as well as the troubleshooting steps you have taken so far.

To check for your current Windows build, press the Windows Key + R and type winver into the dialog box that appears. A window similar to the following should now be displayed:

For more information on how to open a Support ticket, please refer to our Q100064: How to raise a support ticket article.

 

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