Q100234: Will plug-ins for NUKE 10.0 work with NUKE 10.5v1?

Follow

SUMMARY


Plug-ins compiled for NUKE 10.0v1 to 10.0v5 will not work with NUKE 10.5v1.
 
This article explains about NDK plug-in compatibility between versions of NUKE and why NUKE 10.0 plug-ins will need recompiling for NUKE 10.5v1.

MORE INFORMATION


Any Nuke plug-ins compiled using the NDK C++ API will generally be compatible with all v-releases for that major version of Nuke.  For example, if you compiled a plug-in for Nuke 10.0v1 this would work with 10.0v1 to 10.0v5 but it wouldn't work with Nuke 9.0 releases or with the new Nuke 10.5v1 release.

Although the new Nuke 10.5v1 release has a 'Nuke 10' name, there are enough changes under the hood that in terms of Nuke's NDK plug-in API it is a new major version.  This means that your C++ plug-ins for Nuke will need to be recompiled against the Nuke 10.5v1 NDK in order for them to work in Nuke 10.5v1.

This means that the versions of CARA VR and OCULA for Nuke 10.0 will not work with Nuke 10.5 releases and new versions of the plug-ins would need to be released.  Cara VR is now available for Nuke 10.5 with the release of Cara VR 1.0v4 but we are still looking into releasing Ocula for Nuke 10.5 but we cannot promise when this will be.
 
We will update this article when we have more information about Ocula for Nuke 10.5.  The following article explains more about Cara VR compatibility with Nuke 10.5.
Q100233: CaraVR is now compatible with Nuke 10.5
Was this article helpful?
0 out of 0 found this helpful