Q100234: Plug-in compatibility between different versions of Nuke

Follow

SUMMARY

This article explains about NDK plug-in compatibility between versions of Nuke and when NDK plug-ins will need recompiling.

MORE INFORMATION


Any Nuke plug-ins compiled using the NDK C++ API will generally be compatible with all v-releases for the same branch of Nuke.  For example, if you compiled a plug-in for Nuke 10.0v1 this would work with 10.0v1 to 10.0v6 but it wouldn't work with Nuke 9.0 releases or with Nuke 10.5 releases as the branch number has changed.

This also applies to the new Nuke 11.1v1 release.  Although the release has a 'Nuke 11' name, there are enough changes under the hood that in terms of Nuke's NDK plug-in API it is a new major version compared to 11.0.  In the same way that plug-ins for Nuke 10.0 needed recompiling for Nuke 10.5 releases, your C++ plug-ins for Nuke 11.0 will need to be recompiled against the Nuke 11.1v1 NDK in order for them to work in Nuke 11.1v1.

This also means that the versions of Cara VR and Ocula for Nuke 11.0 will not work with Nuke 11.1 releases until new versions of the plug-ins are released.  We are looking into releasing Cara VR and Ocula for Nuke 11.1 but cannot promise at the moment when this will be.
 
The following article explains more about Cara VR compatibility with different branches of Nuke: Q100233: CaraVR compatibility between different branches of Nuke
Was this article helpful?
0 out of 0 found this helpful

Comments