Q100025: How to resolve "The '/Library/Application Support/Luxology/Content/Assets' directory is missing..." Modo LPK file installation error

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SYMPTOMS

Your Modo PKAT .lpk file is not installing correctly, an error message may say the following:  

"The '/Library/Application Support/Luxology/Content/Assets' directory is missing, or you do not have the right permissions for it. Installation will abort."

CAUSE

A missing directory structure or permission problems, stops the kit from installing.

RESOLUTION

There are 2 possible methods to resolve this:

1. Download and install the Content packs: https://www.foundry.com/products/modo/download

Ensure that your user account has read and write permissions to the Assets, Kits and Samples directories found within the Content folder:

  • Windows: C:\Users\<USER>\Documents\Luxology\Content\
  • macOS: /Library/Application Support/Luxology/Content/
  • Linux: /usr/share/Luxology/Content/

2. Alternatively you can unzip the file by changing the extension from .lpk to .zip. You will then have to manually place the content in the proper installation directory.

 

FURTHER HELP

If you encounter any issues performing the steps outlined in this article, then please open a Support ticket and let us know the issue you are encountering, and the troubleshooting steps you have taken so far. For more information on how to do this, please see the following article: Q1000064: How to raise a support ticket. 
 

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