Q100312: How to install plug-ins or kits when the 'Contents Directory Missing' message appears on macOS

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SYMPTOMS

When installing a plug-in or kit into Modo on macOS, a Contents Directory Missing message appears explaining that a missing or restricted directory has caused Modo to abort the installation.

 

error_message.png

Image 1: 'Contents Directory Missing' message

 

CAUSE

Modo requires full 'Read and Write' permissions to the /Library/Application Support/Luxology/ directory in order to install the contents of the plug-in or kit. If the user installing the plug-in or kit does not have read and write permissions to that folder, the installation will be aborted.  

 

RESOLUTION

First confirm that /Library/Application Support/Luxology/Content/Assets directory exists, if it does not you may wish to download and install the content packs from the Modo Product Downloads page. After installing these packs this directory should then be present.

 

If this issue continues to occur after installing these content packs, or if this directory already exists to resolve this problem you will need to set read and write permissions on the relevant folder. To do this please follow the instructions below:

 

1. In a Finder window, navigate to Library > Application Support > Luxology.

2. Right-click on the Luxology folder and select Get Info.

3. Click the padlock in the lower-right and enter your password to edit the settings.

4. In the Sharing and Permissions section, make sure it says Read & Write next to your user. If it doesn't, change it.

5. Click the gear drop down and select Apply to Enclosed items.

 

This will allow you to launch Modo with write permissions to any directory within the Luxology folder, which is needed for installing plug-ins and kits.

You should now be able to install the plug-in or kit successfully, and Modo will prompt you to restart in order to load the plug-in or kit.

 

FURTHER HELP

If you encounter any issues performing the steps outlined in this article, then please open a Support ticket and let us know the issue you are encountering, and the troubleshooting steps you have taken so far. For more information on how to do this, please see the following article: Q1000064: How to raise a support ticket. 

 

 

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